strange boss ns2 behavior

shanejw

Senior member
Messages
698
My Boss noise suppressor is acting weird.  My pedal chain is this - whammy-tuner-wah-phaser-jackhammer distortion-bbe boosta grande-bbe sonic stomp-delay-NS2.  This is whats going on.  When I have the distortion on the NS2 does nothing to the noise, but when I shut off the distortion and just play through clean the LED comes on and the noise happily goes away.  It works this well on the clean or distortion channel of my amp, I was just wondering what the deal is with that pedal not liking the jackhammer.  I just thought it was odd.
 

AToE

Active member
Messages
88
NS2 should be the very first thing your guitar plugs into, and that tuner should be on the end. That particular tuner pedal can overload pedals after it in the chain and cause some distortion (sometimes, sometimes it seems fine). If your NS2 is after the distorition (like it is now) then the distortion is making the background noise higher than the threshold on the NS2, you need to put it before the dist so that there isn't any background noise to amplify in the first place.
 

shanejw

Senior member
Messages
698
I'll try moving it around.  I like to have my tuner after my whammy so i can use the whammy to "tune down" my guitar.  And yes, the tuner makes noise if its on and the distortion is on so I keep it off until I need it.
 

DangerousR6

Senior member
Messages
15,451
AToE is correct, always have a noise suppressor or noise filter at the front of the chain..
 
Top